Отличия в браузере при запуске через студию и робота

При запуске программы через ElectroNeek Studio всё работает корректно, но если сохранить и запускать через neex файл, то браузер открывается с другими масштабами и другими настройками. Это приводит к некорректному исполнению программы, та же самая страница в другом масштабе и элемент уже не видит робот. Как запускать ту же “версию” браузера через neex???

Как вариант установите после открытия браузера “ввод с клавиатуры” в приложении с сочетанием клавиш Win+UP

@AlexandreDupre, добрый вечер!

Данный браузер - Google Chrome? Попробуйте выставить в настройках Robot использование пользовательских настроек:


запуск через neex

запуск через студию, видно что разный масштаб и разные настройки запуска, настройки запуска инкогнито не подгружаются в neex во первых, во вторых даже без них это не все отличия. Как сделать такие же настройки запуска. Из студии запускается будто, я через python автоматизирую, а neex просто браузер с настроками подгружает даже если галочка не стоит!

@AlexandreDupre, следует проверить настройки Robot (не Studio), такое возможно, если у вас указаны какие-либо аргументы командной строки, например, -incognito. Если такое не указано - советую переустановить платформу по следующей инструкции:

  • удалите текущую копию платформы через “Установка и удаление программ”;
  • удалите все папки, имеющие в названии “electroneek” из директории C:\Users\*Ваше имя пользователя*\AppData\Roaming (если папки AppData нет, откройте в “Проводнике” вкладку “Вид” и нажмите на чекбокс “Скрытые элементы”).

  • установите Studio и Robot.
1 симпатия